<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://southpeacenews.com/xmlrpc.php">

<title>Today in High Prairie - February 19, 2020 |</title>

<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://southpeacenews.com/today-in-high-prairie-february-19-2020/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Today in High Prairie - February 19, 2020 |" />
<meta property="og:description" content="Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history and your daily horoscope. Please send your birthdays and community events to southpeacenews@hotmail.com and statsmanchris@hotmail.com What’s Happening Today – February 19, 2020 Storytime for Kids 3-5 Yrs HP Library 10:30-11:30 a.m. Free Play at HP CRC Office&hellip;" />
<meta property="og:url" content="https://southpeacenews.com/today-in-high-prairie-february-19-2020/" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2020-02-19T00:31:05+00:00" />
<meta property="article:modified_time" content="2020-02-19T00:31:07+00:00" />
<meta property="og:updated_time" content="2020-02-19T00:31:07+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history and your daily horoscope. Please send your birthdays and community events to southpeacenews@hotmail.com and statsmanchris@hotmail.com What’s Happening Today – February 19, 2020 Storytime for Kids 3-5 Yrs HP Library 10:30-11:30 a.m. Free Play at HP CRC Office&hellip;" />
<meta name="twitter:title" content="Today in High Prairie - February 19, 2020 |" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://southpeacenews.com/#website","url":"https://southpeacenews.com/","name":"","inLanguage":"en-US","potentialAction":{"@type":"SearchAction","target":"https://southpeacenews.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://southpeacenews.com/today-in-high-prairie-february-19-2020/#webpage","url":"https://southpeacenews.com/today-in-high-prairie-february-19-2020/","name":"Today in High Prairie - February 19, 2020 |","isPartOf":{"@id":"https://southpeacenews.com/#website"},"inLanguage":"en-US","datePublished":"2020-02-19T00:31:05+00:00","dateModified":"2020-02-19T00:31:07+00:00","author":{"@id":"https://southpeacenews.com/#/schema/person/4d917d33c9e3122eb41d63de9a587e14"}},{"@type":["Person"],"@id":"https://southpeacenews.com/#/schema/person/4d917d33c9e3122eb41d63de9a587e14","name":"Admin2015","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://southpeacenews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://southpeacenews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Today in High Prairie &#8211; February 19, 2020 Comments Feed" href="https://southpeacenews.com/today-in-high-prairie-february-19-2020/feed/" />
<link href="https://southpeacenews.com/wp-content/uploads/2017/09/SPN_logo_no_bg.png" rel="icon">
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/southpeacenews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://southpeacenews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css'  href='https://southpeacenews.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=5.3.2' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='cwp-style-css'  href='https://southpeacenews.com/wp-content/plugins/comments-widget-plus/assets/css/cwp.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://southpeacenews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='cff-css'  href='https://southpeacenews.com/wp-content/plugins/custom-facebook-feed/css/cff-style.css?ver=2.12.3' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='likebtn_style-css'  href='https://southpeacenews.com/wp-content/plugins/likebtn-like-button/public/css/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='tptn-style-left-thumbs-css'  href='https://southpeacenews.com/wp-content/plugins/top-10/css/default-style.css?ver=1.0' type='text/css' media='all' />
<style id='tptn-style-left-thumbs-inline-css' type='text/css'>

img.tptn_thumb {
  width: 150px !important;
  height: 150px !important;
}
                

			.tptn_posts_widget2 img.tptn_thumb {
				width: 64px !important;
				height: 64px !important;
			}
			
</style>
<link rel='stylesheet' id='parent-style-css'  href='https://southpeacenews.com/wp-content/themes/freshlife/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://southpeacenews.com/wp-content/themes/freshlife-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-plugins-style-css'  href='https://southpeacenews.com/wp-content/themes/freshlife/assets/css/plugins.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-style-css'  href='https://southpeacenews.com/wp-content/themes/freshlife/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-responsive-style-css'  href='https://southpeacenews.com/wp-content/themes/freshlife/assets/css/responsive.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-child-style-css'  href='https://southpeacenews.com/wp-content/themes/freshlife-child/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://southpeacenews.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.10' type='text/css' media='all' />
<script type='text/javascript' src='https://southpeacenews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://southpeacenews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var likebtn_eh_data = {"ajaxurl":"https:\/\/southpeacenews.com\/wp-admin\/admin-ajax.php","security":"e9e43f5a9f"};
/* ]]> */
</script>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=5.3.2'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/themes/freshlife/assets/js/html5shiv.min.js'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://southpeacenews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://southpeacenews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://southpeacenews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://southpeacenews.com/?p=30754' />
<link rel="alternate" type="application/json+oembed" href="https://southpeacenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsouthpeacenews.com%2Ftoday-in-high-prairie-february-19-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://southpeacenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsouthpeacenews.com%2Ftoday-in-high-prairie-february-19-2020%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.6.4 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-3 { margin:0px width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-4 { margin:0px 0px 0px 0px; width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-2 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-3 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-4 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-8 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-6 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-7 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

			<style type="text/css">.cwp-li {overflow: hidden;}.cwp-avatar {float: left;margin-top: .2em;margin-right: 1em;}.cwp-avatar.rounded .avatar{border-radius:50%;}.cwp-avatar.square .avatar{border-radius:0;}.cwp-comment-excerpt {display: block;color:#787878;}</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #173191; }
</style>
	<!-- Custom CSS -->
<style>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</style>
<!-- Generated by https://wordpress.org/plugins/theme-junkie-custom-css/ -->
	<style>

		#primary-nav ul li a:hover, 		 
		#primary-nav ul li.current-menu-item a,
		#secondary-nav ul li a:hover,
		#secondary-nav ul li.current-menu-item a,
                .pagination .page-numbers.current { 
			background-color: #2266bb;
		}

		a:link,
		a:visited,		
		.widget_tabs .tab-content .entry-title a:hover,
		#site-bottom a:hover,
		.category-box ul li strong a:hover,
		.section-title a:hover,
		.widget_latest_comments a:hover .name,
		.related-posts ul li a:hover .entry-title,
		.widget_tabs .tab-content ul li .entry-title:hover,
		.widget_tabs #tab3 li a span:hover,
 		#secondary-nav ul.sf-menu li li a:hover,
		#primary-nav ul.sf-menu li li a:hover,
		#secondary-nav .sf-menu li li a:hover
		.posts .cat-posts .view-more a,
		.posts .cat-posts a:hover .entry-title,
		.header-social a .fa,
		.posts .sub-cats li:hover > a:after,
		.single .entry-meta .entry-author a:hover,
                .pagination .page-numbers {
			color: #2266bb;
		}

		#secondary-nav .sf-mega {
			border-top: 3px solid #2266bb;
		}

		#secondary-bar {
			border-bottom: 3px solid #2266bb;
		}

		.widget_tabs .tabs-nav li.active a,
		.widget_tabs .tabs-nav li a.selected,
		.widget_tabs .tabs-nav li a:hover {
			background-color: #48d;
		}

		.widget_tabs .tabs-nav li a,
                .author-bio {
			background-color: #eef5ff;
		}

		.widget_tabs .tabs-nav {
			border-bottom: 3px solid #48d;
		}

	</style>
	<script src='https://www.google.com/recaptcha/api.js?render=6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE'></script>
</head>

<body class="post-template-default single single-post postid-30754 single-format-standard custom-background group-blog content-sidebar layout-content-sidebar" itemscope itemtype="http://schema.org/Blog">

<div align="center">

<a href="http://www.southpeacenews.com"><img src="https://southpeacenews.com/wp-content/uploads/2017/02/SPN_WebBanner2017.png"/></a></div>
          



<div id="page" class="container hfeed site clearfix">

	<header id="masthead" class="site-header" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader">

		
	<div id="primary-bar">

			<nav id="primary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">

				<ul id="primary-menu" class="primary-menu sf-menu"><li  id="menu-item-25482" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-25482 home_item"><a href="http://southpeacenews.com/"><i class="fa fa-home"></i> Home</a></li>
<li  id="menu-item-97" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-97"><a href="https://southpeacenews.com/ads/">Ads</a>
<ul class="sub-menu">
	<li  id="menu-item-90" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90"><a href="https://southpeacenews.com/sales/">ADS Sales</a></li>
	<li  id="menu-item-98" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98"><a href="https://southpeacenews.com/notices/">ADS Notices</a></li>
	<li  id="menu-item-95" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="https://southpeacenews.com/employment/">ADS Employment</a></li>
	<li  id="menu-item-89" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89"><a href="https://southpeacenews.com/services/">ADS Services</a></li>
	<li  id="menu-item-93" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93"><a href="https://southpeacenews.com/general/">ADS General</a></li>
	<li  id="menu-item-13201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13201"><a href="https://southpeacenews.com/promo-items/">ADS SPN Promotional Page</a></li>

</ul>
</li>
<li  id="menu-item-94" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-94"><a href="https://southpeacenews.com/events/">Events</a></li>
<li  id="menu-item-21754" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21754"><a target="_blank" href="http://citylive.com/submitted-by-readers">Submit News</a></li>
<li  id="menu-item-18637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18637"><a target="_blank" href="http://classified.citylive.com/">Classifieds</a></li>
<li  id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92"><a href="https://southpeacenews.com/horoscopes/">Horoscopes</a></li>
</ul>
			</nav><!-- #primary-nav -->

			<div class="header-search">
				<form method="get" class="searchform" id="search-form" action="https://southpeacenews.com/" role="search">
					<input type="search" class="search-field field" placeholder="Press enter to search &hellip;" value="" name="s" title="Search for:" />
					<button name="search" id="search"><i class="fa fa-search"></i></button>
				</form>
			</div>

	</div>


		<div class="site-branding clearfix">
				<div id="logo">
<h1 class="site-title" itemprop="headline"><a href="https://southpeacenews.com" itemprop="url" rel="home"><span itemprop="headline"></span></a></h1>
<h2 class="site-description" itemprop="description"></h2></div>
				    <div id="header-widget-area" class="chw-widget-area widget-area" role="complementary">
    <div class="chw-widget"><!-- Either there are no banners, they are disabled or none qualified for this location! --></div>    </div>
 			
			<div style="margin-bottom: 5px;">
				<div class="g g-2"><div class="g-dyn a-85 c-1"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Horoscope_Top']);" href="http://southpeacenews.com/horoscopes/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Horoscope_Top']);" src="https://southpeacenews.com/wp-content/uploads/2017/01/Horroscope.png" /></a></div><div class="g-dyn a-833 c-2"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'RoyalLepage_HenryVos_Bremont_TOP']);" href="https://southpeacenews.com/sales/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'RoyalLepage_HenryVos_Bremont_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2020/02/RoyalLepage_HenryVos_Bremont_TOP.png" /></a></div><div class="g-dyn a-640 c-3"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Kaft_BusDir_BOTH_TOP.']);" href="http://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Kaft_BusDir_BOTH_TOP.']);" src="https://southpeacenews.com/wp-content/uploads/2019/02/Kaft_BusDir_BOTH_TOP.png" /></a></div><div class="g-dyn a-462 c-4"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Classified_01']);" href="http://classified.citylive.com/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Classified_01']);" src="https://southpeacenews.com/wp-content/uploads/2018/08/Classified_02.png" /></a></div><div class="g-dyn a-537 c-5"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'ConnectWithMoreCustomers_TOP']);" href="http://southpeacenews.com/promo-items/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'ConnectWithMoreCustomers_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2018/09/ConnectWithMoreCustomers_TOP.png" /></a></div><div class="g-dyn a-745 c-6"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'AreYouAClub_TOP']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'AreYouAClub_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2019/07/AreYouAClub_TOP.png" /></a></div><div class="g-dyn a-828 c-7"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'PrairieRiverGas_EquipmentRegistry_TOP']);" href="https://southpeacenews.com/notices/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'PrairieRiverGas_EquipmentRegistry_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2020/02/PrairieRiverGas_EquipmentRegistry_TOP.png" /></a></div><div class="g-dyn a-726 c-8"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'LetterToTheEditor']);" href="http://southpeacenews.com/general-comments/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'LetterToTheEditor']);" src="https://southpeacenews.com/wp-content/uploads/2019/07/LetterToTheEditor.png" /></a></div><div class="g-dyn a-103 c-9"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Bus Dir_Top']);" href="http://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Bus Dir_Top']);" src="https://southpeacenews.com/wp-content/uploads/2017/03/Bus-Dir_Top.png" /></a></div><div class="g-dyn a-791 c-10"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'TellUs_Event_TOP']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'TellUs_Event_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2019/10/TellUs_Event_TOP.png" /></a></div><div class="g-dyn a-804 c-11"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'MaherAuto_OilChange_TOP']);" href="https://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'MaherAuto_OilChange_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2019/12/MaherAuto_OilChange_TOP.png" /></a></div><div class="g-dyn a-718 c-12"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Advert_JobOpportunity_TOP']);" href="http://southpeacenews.com/employment/#SPNJOB"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Advert_JobOpportunity_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2019/07/Advert_JobOpportunity_TOP.png" /></a></div></div></div>
			<div style="margin-bottom: 5px;">
				<div class="g g-4"><div class="g-dyn a-804 c-1"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'MaherAuto_OilChange_TOP']);" href="https://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'MaherAuto_OilChange_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2019/12/MaherAuto_OilChange_TOP.png" /></a></div><div class="g-dyn a-726 c-2"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'LetterToTheEditor']);" href="http://southpeacenews.com/general-comments/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'LetterToTheEditor']);" src="https://southpeacenews.com/wp-content/uploads/2019/07/LetterToTheEditor.png" /></a></div><div class="g-dyn a-462 c-3"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Classified_01']);" href="http://classified.citylive.com/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Classified_01']);" src="https://southpeacenews.com/wp-content/uploads/2018/08/Classified_02.png" /></a></div><div class="g-dyn a-103 c-4"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Bus Dir_Top']);" href="http://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Bus Dir_Top']);" src="https://southpeacenews.com/wp-content/uploads/2017/03/Bus-Dir_Top.png" /></a></div><div class="g-dyn a-718 c-5"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Advert_JobOpportunity_TOP']);" href="http://southpeacenews.com/employment/#SPNJOB"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Advert_JobOpportunity_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2019/07/Advert_JobOpportunity_TOP.png" /></a></div><div class="g-dyn a-640 c-6"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Kaft_BusDir_BOTH_TOP.']);" href="http://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Kaft_BusDir_BOTH_TOP.']);" src="https://southpeacenews.com/wp-content/uploads/2019/02/Kaft_BusDir_BOTH_TOP.png" /></a></div><div class="g-dyn a-833 c-7"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'RoyalLepage_HenryVos_Bremont_TOP']);" href="https://southpeacenews.com/sales/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'RoyalLepage_HenryVos_Bremont_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2020/02/RoyalLepage_HenryVos_Bremont_TOP.png" /></a></div><div class="g-dyn a-791 c-8"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'TellUs_Event_TOP']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'TellUs_Event_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2019/10/TellUs_Event_TOP.png" /></a></div><div class="g-dyn a-85 c-9"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Horoscope_Top']);" href="http://southpeacenews.com/horoscopes/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Horoscope_Top']);" src="https://southpeacenews.com/wp-content/uploads/2017/01/Horroscope.png" /></a></div><div class="g-dyn a-828 c-10"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'PrairieRiverGas_EquipmentRegistry_TOP']);" href="https://southpeacenews.com/notices/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'PrairieRiverGas_EquipmentRegistry_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2020/02/PrairieRiverGas_EquipmentRegistry_TOP.png" /></a></div><div class="g-dyn a-537 c-11"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'ConnectWithMoreCustomers_TOP']);" href="http://southpeacenews.com/promo-items/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'ConnectWithMoreCustomers_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2018/09/ConnectWithMoreCustomers_TOP.png" /></a></div><div class="g-dyn a-745 c-12"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'AreYouAClub_TOP']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'AreYouAClub_TOP']);" src="https://southpeacenews.com/wp-content/uploads/2019/07/AreYouAClub_TOP.png" /></a></div></div></div>
		</div>

			
	<div id="secondary-bar" class="clearfix">

			<nav id="secondary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">

				<ul id="secondary-menu" class="secondary-menu sf-menu"><li  id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-47"><a href="https://southpeacenews.com/category/news/">News</a>
<ul class="sub-menu">
	<li  id="menu-item-15686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15686"><a href="https://southpeacenews.com/category/news/schools/">Schools</a></li>
	<li  id="menu-item-28794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28794"><a href="https://southpeacenews.com/category/news/court-docket/">Court Docket</a></li>

</ul>
</li>
<li  id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://southpeacenews.com/category/sports/">Sports</a></li>
<li  id="menu-item-51" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51"><a href="https://southpeacenews.com/category/councils/">Councils</a></li>
<li  id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55"><a href="https://southpeacenews.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li  id="menu-item-14593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14593"><a href="https://southpeacenews.com/category/opinion/polls/">Polls</a></li>

</ul>
</li>
<li  id="menu-item-58" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58"><a href="https://southpeacenews.com/category/events/">Events</a></li>
<li  id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://southpeacenews.com/category/obituaries/">Obituaries</a></li>
<li  id="menu-item-57" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57"><a href="https://southpeacenews.com/category/uncategorized/">Uncategorized</a></li>
<li  id="menu-item-27004" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27004"><a href="https://southpeacenews.com/category/today-in-hp/">Today in HP</a></li>
</ul>
			</nav><!-- #secondary-nav -->

			
	</div>


	</header><!-- #masthead -->

	<div id="site-content" class="site-content">

	<main id="main" class="site-main clearfix" role="main" class="content">
		<div id="primary" class="content-area">

			<div id="content" class="single">

				<div id="breadcrumbs">

			
		<div class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><span class="trail-begin"><a href="https://southpeacenews.com" title="" rel="home">Home</a></span>
			 <span class="sep"><i class="fa fa-caret-right"></i></span> <a href="https://southpeacenews.com/category/news/" rel="tag">News</a>
			 <span class="sep"><i class="fa fa-caret-right"></i></span> <span class="trail-end">Today in High Prairie &#8211; February 19, 2020</span>
		</div>	
</div>
				
					<article id="post-30754" class="post-30754 post type-post status-publish format-standard hentry category-news no-post-thumbnail entry" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost">

	<header class="entry-header">
		<h1 class="page-title" itemprop="headline">Today in High Prairie &#8211; February 19, 2020</h1>
				<div class="entry-meta">

				<span class="entry-date">
				<time class="published" datetime="2020-02-18T17:31:05-07:00" itemprop="datePublished">February 18, 2020</time>
			</span>

			<span class="sep">&#183;</span>

			by			
				<span class="entry-author author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a class="url fn n" href="https://southpeacenews.com/author/admin2015/" itemprop="url"><span itemprop="name">Admin2015</span></a></span>

			<span class="sep">&#183;</span>

					
							<span class="entry-comments"><i class="fa fa-comment-o"></i> <a href="https://southpeacenews.com/today-in-high-prairie-february-19-2020/#respond" itemprop="discussionURL">0</a></span>
			
				
		</div>

			</header><!-- .entry-header -->

	
	<div class="entry-content" itemprop="articleBody">
		
<p>Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history and your daily horoscope. Please send your birthdays and community events to southpeacenews@hotmail.com and statsmanchris@hotmail.com</p>



<p>What’s Happening Today – February 19, 2020</p>



<p>Storytime for Kids 3-5 Yrs HP Library 10:30-11:30 a.m.</p>



<p>Free Play at HP CRC Office 10 a.m.-noon.</p>



<p>CRC Parents N” Tots at Sunset House at 10 a.m.</p>



<p>Grouard Seniors meeting at NLC Cafeteria at 12:30 p.m.</p>



<p>CRC Baby &amp; Me at HP CRC Office at 1 p.m.</p>



<p>Games Days at Kinuso Seniors Centre from 1-3:30 p.m.</p>



<p>Bingo at Kinuso Ag Hall [doors open at 5:30 p.m.] at 6:45
p.m.</p>



<p>Today’s Local Birthdays – High Prairie – February 19,
2020</p>



<p>Derian Haire</p>



<p>Tyler Shantz</p>



<p>Tara Badget</p>



<p>Today’s Local Birthdays – Faust – February 19, 2020</p>



<p>Lisa Sowan</p>



<p>Thomas Morland</p>



<p>Patrick Chalifoux</p>



<p>Troy Dillman</p>



<p>James Davis</p>



<p>Today’s Celebrity Birthdays – February 19, 2020</p>



<p>1473 &#8211; Nicolaus Copernicus, Polish astronomer</p>



<p>1888 &#8211; Aurora Quezon, 1st Lady of Philippines</p>



<p>1893 &#8211; Cedric Hardwicke, Peter Pan actor</p>



<p>1911 &#8211; Merle Oberon, Wuthering Heights actress</p>



<p>1916 &#8211; Eddie Arcaro, Hall of Fame jockey</p>



<p>1924 &#8211; Lee Marvin, Cat Ballou actor</p>



<p>1940 &#8211; Smokey Robinson, American soul singer</p>



<p>1940 &#8211; Bobby Rogers, Miracles vocalist</p>



<p>1946 &#8211; Paul Dean, Loverboy guitarist</p>



<p>1948 &#8211; Tony Iommi, Black Sabbath guitarist</p>



<p>1955 &#8211; Jeff Daniels, Dumb &amp; Dumber actor</p>



<p>1957 – Falco, Rock Me Amadeus vocalist</p>



<p>1959 &#8211; Roger Goodell, American NFL Commissioner</p>



<p>1962 &#8211; Hana Mandlikova, Czech tennis player</p>



<p>1966 &#8211; Justine Bateman, Family Ties actress</p>



<p>1985 &#8211; Haylie Duff, American singer/actress</p>



<p>This Day in Local History – February 19, 2020</p>



<p>Feb. 19, 1914: New fire equipment arrives in Grouard that
is capable of shooting a one-inch stream of water 90 feet.</p>



<p>Feb. 19, 1962: Former builder of the Faust Community
Hall, William Robinson, is elected president of the Faust Community League.</p>



<p>Feb. 19, 1973: The Gamelin Home is renamed J.B. Wood
Nursing Home.</p>



<p>Feb. 19, 1978: Don Powney is one of a few people trying
to get a judo club operating in High Prairie. A meeting is called with 32
people attending and the club is officially launched.</p>



<p>Feb. 19, 1979: High Prairie Councillor Rollie Johnson
resigns.</p>



<p>Feb. 19, 1980: PC Jack Shields wins the Athabasca
constituency but Pierre Trudeau is returned to power in the federal election.
Shields would serve until 1993.</p>



<p>Feb. 19, 1984: High Prairie Team Honda wins the gold
medal in senior men&#8217;s floor hockey at the Peace Winter Games held in High
Prairie.</p>



<p>Feb. 19, 1985: Western Liquidators celebrates its grand
opening.</p>



<p>Feb. 19, 1986: South Peace News reports construction is
proceeding well on the Smoky River Ski Hill.</p>



<p>Feb. 19, 1989: Bernie Poloz&#8217;s rink finishes in second
place at the Alberta Mixed Curling Championships in Grande Prairie. Third Kay
Savill is named to the all-star team.</p>



<p>Feb. 19, 1991: In a final effort to keep Carole Bannister
School open, HPSD plans to ask Kinuso parents if their children will attend
school in Grades 4-6. The proposal is rejected.</p>



<p>Feb. 19, 1993: A potential thief is caught on an in-store
camera at Tags.</p>



<p>Feb. 19, 1997: Kevin Laboucan, 27, of Gift Lake dies when
a tree falls on him during logging.</p>



<p>Feb. 19, 2000: Goju-Ryu karate member Josh McNeil wins a
gold medal at the Alberta Winter Games in Sherwood Park.</p>



<p>Feb. 19, 2003: Blake Noecker tells South Peace News he is
trying to revive Citizens on Patrol.</p>



<p>Feb. 19, 2008: The 13.9-acre land deal to officially
build the new High Prairie Hospital on land at Peavine Estates is signed.</p>



<p>This Day in World History – February 19, 2020</p>



<p>&nbsp;356 &#8211; Emperor
Constantius II shuts all heathen temples.</p>



<p>1600 &#8211; Peruvian volcano erupts, most violent eruption in
SA history.</p>



<p>1797 &#8211; One-third of papal domain ceded to France.</p>



<p>1819 &#8211; British explorer William Smith discovers South
Shetland Islands.</p>



<p>1831 &#8211; 1st practical US coal-burning locomotive makes 1st
trial run.</p>



<p>1856 &#8211; Tin-type camera patented by Hamilton Smith.</p>



<p>1878 &#8211; Thomas Edison granted a patent for phonograph.</p>



<p>1881 &#8211; Kansas becomes 1st state to prohibit all alcoholic
beverages.</p>



<p>1906 &#8211; Keith Kellogg co-founds Battle Creek Toasted Corn
Flake Company.</p>



<p>1913 &#8211; 1st prize inserted into a Cracker Jack box.</p>



<p>1922 &#8211; Ed Wynn becomes 1st talent to sign as a radio
entertainer.</p>



<p>1929 &#8211; Medical diathermy machine 1st used.</p>



<p>1933 &#8211; Prussian minister Goering bans all Catholic
newspapers.</p>



<p>1945 &#8211; 980 Japanese soldiers killed by crocodiles in 2
days in Burma.</p>



<p>1945 &#8211; Brotherhood Day 1st celebrated.</p>



<p>1960 &#8211; Bill Keane’s “Family Circus” cartoon strip debuts.</p>



<p>1982 &#8211; Hanneke Jagersma Netherlands’ 1st Communist mayor.</p>



<p>1985 &#8211; Canned &amp; bottled Cherry Coke introduced by
Coca-Cola.</p>



<p>1985 &#8211; Mickey Mouse welcomed in China.</p>



<p>1986 &#8211; USSR launches Mir space station into Earth orbit.</p>



<p>1998 &#8211; US hockey team destroys their rooms in Japan.</p>



<p>2002 &#8211; NASA space probe begins to map the surface of
Mars.</p>



<p>2007 &#8211; Blogging website Tumblr is founded by David Karp
in New York.</p>



<p>2018 &#8211; At least 17 killed when a garbage mound collapses
in Mozambique.</p>



<p>Today’s Horoscopes – February 19, 2020</p>



<p>Cancer [June 22 – July 22] – Finances may cause an upset
between you and a friend today. Perhaps this person owes you money and can’t
pay it back, or vice versa. If this is the case, try to work out some kind of
arrangement that suits you both. There’s always a way to create a win-win
situation if you don’t both get so angry that your objectivity is totally wiped
out. Stay calm and focused and all should be well. Hang in there.</p>



<p>Leo [July 23 – Aug. 23] – A social event could put you in
touch with someone who’s carrying around a lot of bitterness and anger. This
probably won’t be very pleasant for you, as this person could well see you as
the perfect listening post for all their problems. Don’t feel trapped! Be
polite but make your excuses as soon as you can. There are other friends
present whose company you’ll enjoy a lot more!</p>



<p>Virgo [Aug. 24 – Sept. 22] – The workplace could be very
hectic today as a colleague prepares to leave on an important business trip.
Nerves could be strained and tempers short. Try to stay focused and get
everything necessary done without making yourself crazy. You may be the one who
keeps everyone else from going crazy, although you might consider hiding in the
closet yourself. Say a prayer of thanks when your colleague finally rides off
in the taxi.</p>



<p>Libra [Sept. 23 – Oct. 23] – You may have a wonderful day
today. Your imagination, intuition, and creativity are all high, and
inspiration for new artistic works could be filling your heart and brain.
You’ll be all too happy to discuss your ideas with anyone who shows an
interest. The one dark spot in the day might be that a child, close friend, or
lover goes into a snit because he or she feels ignored. Don’t worry. They’ll
come out of it.</p>



<p>Scorpio [Oct. 24 – Nov. 22] – Your home could be a very
busy place today. Visitors could come and go throughout the day, probably
annoying you at times. You might also find yourself having to soothe angry outbursts
on the part of a member of your household. Take care, however, that this
person’s problem doesn’t get you so inflamed that you go into a fit of anger,
too. Try to stay calm and focused and you’ll get through the day.</p>



<p>Sagittarius [Nov. 23 – Dec. 21] – Someone you work with
might need a sympathetic shoulder to cry on today. Stresses on the job extend
beyond everyone’s capacity to endure, so don’t be surprised if at some point a
colleague sheds a few tears. You might find your patience pushed beyond its
normal limits. On days like this it’s best to work as quickly as you can, stay
focused, and go for a drink after you leave work. Then have a nice walk home!</p>



<p>Capricorn [Dec. 22 – Jan. 20] – Children or possibly some
close friends or a love interest could be upset today. The financial coffers
aren’t full enough to afford something they think they absolutely have to have
right now. You might find yourself having to soothe their feelings, reassuring
them that “not now” doesn’t necessarily mean “never”. If they don’t respond,
don’t keep pushing. They’ll have to come to terms with the situation in their
own way.</p>



<p>Aquarius [Jan. 21 – Feb. 18] – Worry about a family
member may be on your mind today. This person could be all wrought up over
work, money, or possibly a love affair that’s broken off. Say whatever
reassuring words you can muster, but don’t expect him or her to respond, and
don’t fall into the trap of feeling that your kind words were all in vain. They
did register. It’s just going to take this person a while to come to terms with
the situation.</p>



<p>Pisces [Feb. 19 – March 20] – Uneasy feelings may be
plaguing you throughout the day. There could appear to be no valid reason for
this. Everything seems to be going well for you, and no one close to you has
anything heavy going on. It’s probably nothing earthshaking. You may just be
intuitively picking up on the troubles and anxieties of people you pass on the
street. Your intuition is high today, so you could psychically sense just about
anything. Hang in there!</p>



<p>Aries [March 21 – April 20] – A friend, perhaps a woman,
could well be upset or even angry with you today. Money might be involved in
some way. There may be nothing you can do to reassure her at this time, so it’s
best to give what reassurances you can and then back off. Whatever has gone
wrong, she’s probably overreacting, and eventually she’ll see that. In the
meantime, you do what you can to work off your own anxieties. Hang in there!</p>



<p>Taurus [April 21 – May 21] – Is your boss a woman? If so,
stay out of her way today. To put it mildly, she isn’t in a good mood. Work
hard, be very sweet to everyone, and make copious use of your innate diplomacy.
You may be on the receiving end of some sharp words, but by remaining focused
and continuing your routine in your usual efficient manner, you should avoid
any major blowups. Try to stay calm, and hope she goes home early!</p>



<p>Gemini [May 22 – June 21] – Travel may cause more problems than it’s worth today. You may forget some vital items when packing or there could be too little time to get everything ready. Your plane could be delayed or something valuable lost. Try to short-circuit potential problems. Use a checklist when packing, keep valuables close to you, and take lots of books and CDs in case you have to wait out a delay. In spite of it all, have fun!</p>



<p></p>
<div class="likebtn_container" style="clear:both;text-align:center;"><!-- LikeBtn.com BEGIN --><span class="likebtn-wrapper"  data-identifier="post_30754"  data-site_id="5a85da066fd08b8d780a138a"  data-theme="large"  data-ef_voting="heartbeat"  data-show_dislike_label="true"  data-counter_type="percent"  data-voting_frequency="604800"  data-white_label="true"  data-rich_snippet="true"  data-i18n_like="This informed me"  data-i18n_dislike="This not needed"  data-i18n_after_like="Liked"  data-i18n_after_dislike="Disliked"  data-i18n_like_tooltip="I found the content of this post interesting"  data-i18n_dislike_tooltip="This post did not interest me"  data-i18n_unlike_tooltip="I liked this already"  data-i18n_undislike_tooltip="I disliked this already"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://southpeacenews.com/today-in-high-prairie-february-19-2020/"  data-item_title="Today in High Prairie - February 19, 2020"  data-item_date="2020-02-18T17:31:05-07:00"  data-engine="WordPress"  data-plugin_v="2.6.24"  data-prx="https://southpeacenews.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh" ></span><!-- LikeBtn.com END --></div><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- AdsenseResponsive01 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3165736599172791"
     data-ad-slot="6075938174"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!-- .entry-content -->

	<footer class="entry-footer">

		<span class="entry-cats"><strong>Filed in:</strong> <a href="https://southpeacenews.com/category/news/" rel="category tag">News</a></span>
	</footer><!-- .entry-footer -->

	<div class="clearfix"></div>

	
			<div class="entry-share clearfix">
			<h3>Share this post</h3>
			<ul>
				<li class="twitter"><a href="https://twitter.com/intent/tweet?text=Today in High Prairie &#8211; February 19, 2020&url=https%3A%2F%2Fsouthpeacenews.com%2Ftoday-in-high-prairie-february-19-2020%2F" target="_blank"><i class="fa fa-twitter"></i>Twitter</a></li>
				<li class="facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fsouthpeacenews.com%2Ftoday-in-high-prairie-february-19-2020%2F" target="_blank"><i class="fa fa-facebook"></i>Facebook</a></li>
				<li class="google-plus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fsouthpeacenews.com%2Ftoday-in-high-prairie-february-19-2020%2F" target="_blank"><i class="fa fa-google-plus"></i>Google+</a></li>
				<li class="linkedin"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fsouthpeacenews.com%2Ftoday-in-high-prairie-february-19-2020%2F&title=Today in High Prairie &#8211; February 19, 2020" target="_blank"><i class="fa fa-linkedin"></i>LinkedIn</a></li>
				<li class="pinterest"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fsouthpeacenews.com%2Ftoday-in-high-prairie-february-19-2020%2F&media=" target="_blank"><i class="fa fa-pinterest"></i>Pinterest</a></li>				
				<li class="email"><a href="mailto:"><i class="fa fa-envelope-o"></i>Email</a></li>
			</ul>
		</div><!-- .entry-share -->
		
	
			<div class="related-posts">
				<h3>Recommended for You</h3>
				<ul class="clearfix">
											<li>
							<a href="https://southpeacenews.com/man-delivers-emotional-plea-to-judge/">
																	<h2 class="entry-title">Man delivers emotional plea to judge</h2>							</a>
						</li>
											<li>
							<a href="https://southpeacenews.com/metis-organization-first-to-establish-right-to-consultation/">
																	<h2 class="entry-title">Métis organization first to establish right to consultation</h2>							</a>
						</li>
											<li>
							<a href="https://southpeacenews.com/grade-2-students-learning-inuktitut-words/">
									<img width="200" height="113" src="https://southpeacenews.com/wp-content/uploads/2020/02/19feb20_hpe1b-200x113.jpg" class="attachment-freshlife-related size-freshlife-related wp-post-image" alt="Grade 2 students learning Inuktitut words" itemprop="image" />								<h2 class="entry-title">Grade 2 students learning Inuktitut words</h2>							</a>
						</li>
											<li>
							<a href="https://southpeacenews.com/toy-store-teaches-the-value-of-money/">
									<img width="200" height="113" src="https://southpeacenews.com/wp-content/uploads/2020/02/19feb20_jous1c-200x113.jpg" class="attachment-freshlife-related size-freshlife-related wp-post-image" alt="Toy store teaches the value of money" itemprop="image" />								<h2 class="entry-title">Toy store teaches the value of money</h2>							</a>
						</li>
									</ul>
			</div>
		
			
</article><!-- #post-## -->
					
<div id="comments" class="comments-area">

	
	
	
				<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Post Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/today-in-high-prairie-february-19-2020/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://southpeacenews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author"> Name <span class="required">*</span></label> <input class="txt" id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email"> Email <span class="required">*</span></label> <input class="txt" id="email" name="email" type="email" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url"> Website</label> <input class="txt" id="url" name="url" type="url" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='30754' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="52dab6ffab" /></p><input class="btn" name="submit" type="submit" id="submit" value="Post Comment" /><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="150"/></p></form>	</div><!-- #respond -->
		
</div><!-- #comments -->
				
			</div>

		</div><!-- #primary -->

		
<div id="secondary" class="widget-area widget-primary sidebar" role="complementary" aria-label="Primary Sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	<aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="http://highprairie.citylive.com/hp-events-calendar/" target="_blank" rel="noopener noreferrer"><img src="https://highprairie.com/wp-content/uploads/2016/11/Calendar_Small_Banner.png" alt="click for the High Prairie & Area Events Calendar"></a>
</div></aside><aside id="ajdg_grpwidgets-2" class="widget ajdg_grpwidgets"><div class="g g-1"><div class="g-dyn a-827 c-1"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'PrairieRiverGas_EquipmentRegistry_SIDE']);" href="https://southpeacenews.com/notices/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'PrairieRiverGas_EquipmentRegistry_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2020/02/PrairieRiverGas_EquipmentRegistry_SIDE.png" /></a></div><div class="g-dyn a-639 c-2"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Kaft_BusDir_BOTH_SIDE']);" href="http://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Kaft_BusDir_BOTH_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2019/02/Kaft_BusDir_BOTH_SIDE.png" /></a></div><div class="g-dyn a-790 c-3"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'TellUs_Event_SIDE']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'TellUs_Event_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2019/10/TellUs_Event_SIDE.png" /></a></div><div class="g-dyn a-138 c-4"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Share Your Scoop side']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Share Your Scoop side']);" src="https://southpeacenews.com/wp-content/uploads/2017/10/ShareYourScoop.png" /></a></div><div class="g-dyn a-803 c-5"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'MaherAuto_OilChange_SIDE']);" href="https://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'MaherAuto_OilChange_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2019/12/MaherAuto_OilChange_SIDE.png" /></a></div><div class="g-dyn a-65 c-6"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'We Want News-Side']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'We Want News-Side']);" src="https://southpeacenews.com/wp-content/uploads/2016/10/WeWantNews_side_png.png" /></a></div><div class="g-dyn a-834 c-7"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'RoyalLepage_HenryVos_Bremont_SIDE']);" href="https://southpeacenews.com/sales/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'RoyalLepage_HenryVos_Bremont_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2020/02/RoyalLepage_HenryVos_Bremont_SIDE.png" /></a></div><div class="g-dyn a-198 c-8"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'NoticeofMeeting_side']);" href=" http://southpeacenews.com/notices/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'NoticeofMeeting_side']);" src="https://southpeacenews.com/wp-content/uploads/2018/01/NoticeOfMeeting_Side.png" /></a></div></div></aside><aside id="awesomeweatherwidget-4" class="widget widget_awesomeweatherwidget"><div id="awe-ajax-awesome-weather-peace-river-ab" class="awe-ajax-awesome-weather-peace-river-ab awe-weather-ajax-wrap" style=""><div class="awe-loading"><i class="wi wi-day-sunny"></i></div></div><script type="text/javascript"> jQuery(document).ready(function() { awe_ajax_load({"id":"awesome-weather-peace-river-ab","locale":"","location":"PEACE RIVER AB","owm_city_id":"6100069","override_title":"HIGH PRAIRIE - PEACE RIVER ","size":"wide","units":"C","forecast_days":"10","hide_stats":0,"show_link":0,"background":"","custom_bg_color":"","use_user_location":0,"allow_user_to_change":0,"show_icons":0,"extended_url":"","extended_text":"","background_by_weather":1,"text_color":"#eeee22","hide_attribution":1,"skip_geolocate":0,"latlng":"","ajaxurl":"https:\/\/southpeacenews.com\/wp-admin\/admin-ajax.php","via_ajax":1}); }); </script></aside><aside id="text-2" class="widget widget_text">			<div class="textwidget"><center><p><a href ="https://weather.gc.ca/city/pages/ab-25_metric_e.html"><img src ="https://smokyriverexpress.com/wp-content/uploads/2016/01/sun-1.gif"</img>   Environment Canada Forecast   <img src ="https://smokyriverexpress.com/wp-content/uploads/2016/01/sun-1.gif"</img></a></p><p><a href="https://511.alberta.ca/map#:Alerts"><img src ="https://smokyriverexpress.com/wp-content/uploads/2016/01/Snowflake.gif"</img>   Alberta 511 Road Reports   <img src ="https://smokyriverexpress.com/wp-content/uploads/2016/01/Snowflake.gif"</a></P>
<p><a href ="http://www.emergencyalert.alberta.ca/"><img src ="https://smokyriverexpress.com/wp-content/uploads/2016/01/Fire.png"</img>   Alberta Wildfire Status Map   <img src ="https://smokyriverexpress.com/wp-content/uploads/2016/01/Fire.png"</img></a></p></center></div>
		</aside><aside id="cwp-widget-2" class="widget widget_recent_comments comments_widget_plus"><h3 class="widget-title">Recent Comments</h3><ul class="cwp-ul "><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://southpeacenews.com/water-study-to-determine-hps-future-requirements/#comment-5821"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">K Bains</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://southpeacenews.com/water-study-to-determine-hps-future-requirements/#comment-5821">Water study to determine HP&#8217;s future requirements</a></span><span class="comment-excerpt cwp-comment-excerpt">It will cost local taxpayers $200,000! Where does CAO Brian Martinson thinks Alber&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://southpeacenews.com/with-friends-like-this-who-needs-enemies/#comment-5805"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Admin2015</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://southpeacenews.com/with-friends-like-this-who-needs-enemies/#comment-5805">With friends like this, who needs enemies?</a></span><span class="comment-excerpt cwp-comment-excerpt">And where have the resources come from to pay for all the services the cities enjo&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://southpeacenews.com/with-friends-like-this-who-needs-enemies/#comment-5791"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Ben Dover</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://southpeacenews.com/with-friends-like-this-who-needs-enemies/#comment-5791">With friends like this, who needs enemies?</a></span><span class="comment-excerpt cwp-comment-excerpt">What a stupid article! Guess who has paid for High Prairie's policing for Years? C&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://southpeacenews.com/33-people-charged-in-trafficking-of-fish/#comment-5735"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Elizabeth</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://southpeacenews.com/33-people-charged-in-trafficking-of-fish/#comment-5735">33 people charged in trafficking of fish</a></span><span class="comment-excerpt cwp-comment-excerpt">Plenty of fish in the lake.. no one in a thieve.. what about all them sport fisher&hellip;</span></li></ul><!-- Generated by https://wordpress.org/plugins/comments-widget-plus/ --></aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><h3 class="widget-title">Your Thoughts Are Welcome</h3><div class="textwidget custom-html-widget">Comments for particular stories should go on the comment section below that story. General comments submit <a href="http://southpeacenews.com/general-comments/">HERE</a></div></aside><aside id="ajdg_grpwidgets-3" class="widget ajdg_grpwidgets"><div class="g g-3"><div class="g-dyn a-639 c-1"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Kaft_BusDir_BOTH_SIDE']);" href="http://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Kaft_BusDir_BOTH_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2019/02/Kaft_BusDir_BOTH_SIDE.png" /></a></div><div class="g-dyn a-827 c-2"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'PrairieRiverGas_EquipmentRegistry_SIDE']);" href="https://southpeacenews.com/notices/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'PrairieRiverGas_EquipmentRegistry_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2020/02/PrairieRiverGas_EquipmentRegistry_SIDE.png" /></a></div><div class="g-dyn a-790 c-3"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'TellUs_Event_SIDE']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'TellUs_Event_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2019/10/TellUs_Event_SIDE.png" /></a></div><div class="g-dyn a-803 c-4"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'MaherAuto_OilChange_SIDE']);" href="https://southpeacenews.com/services/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'MaherAuto_OilChange_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2019/12/MaherAuto_OilChange_SIDE.png" /></a></div><div class="g-dyn a-834 c-5"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'RoyalLepage_HenryVos_Bremont_SIDE']);" href="https://southpeacenews.com/sales/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'RoyalLepage_HenryVos_Bremont_SIDE']);" src="https://southpeacenews.com/wp-content/uploads/2020/02/RoyalLepage_HenryVos_Bremont_SIDE.png" /></a></div></div></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="https://quirknews.com/" target="_blank" rel="noopener noreferrer"><img src="https://southpeacenews.com/wp-content/uploads/2017/01/QuirkNewsButton.png" alt="click this button to go to QuirkNews.com">
	Click above to go to QuirkNews.com</a></center>
<iframe style="border: 3px solid black" src="https://quirknews.com/quirk-links/" width="420" height="500" frameborder="0" allowfullscreen="allowfullscreen"></iframe></div></aside><aside id="widget_tptn_pop-2" class="widget tptn_posts_list_widget"><h3 class="widget-title">&#8212;&#8212; MOST READ STORIES &#8211; PAST 14 DAYS &#8212;&#8212;</h3><div class="tptn_posts_daily  tptn_posts_widget tptn_posts_widget2"><ul><li><a href="https://southpeacenews.com/guy-man-wins-331763-60-in-6-49-lottery-draw/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/uploads/2020/02/Maisonneuve-Bernard-1-64x64.jpg" class="tptn_thumb tptn_featured" alt="Guy man wins $331,763.60 in 6/49 lottery draw" title="Guy man wins $331,763.60 in 6/49 lottery draw" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/guy-man-wins-331763-60-in-6-49-lottery-draw/"     class="tptn_link"><span class="tptn_title">Guy man wins $331,763.60 in 6/49 lottery draw</span></a><span class="tptn_excerpt"> Chris Clegg South Peace News Bernard Maisonneuve was tidying up from the holidays when he discovered something big.&hellip;</span></span></li><li><a href="https://southpeacenews.com/with-friends-like-this-who-needs-enemies/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/uploads/2020/01/clegg-logo-2020-64x64.jpg" class="tptn_thumb tptn_featured" alt="With friends like this, who needs enemies?" title="With friends like this, who needs enemies?" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/with-friends-like-this-who-needs-enemies/"     class="tptn_link"><span class="tptn_title">With friends like this, who needs enemies?</span></a><span class="tptn_excerpt"> The written comments in a letter Jan. 20 from Alberta Justice Minister Doug Schweitzer to Rural Municipalities of&hellip;</span></span></li><li><a href="https://southpeacenews.com/2020-family-day-lineup-for-south-peace-smoky-river-and-peace-river-regions/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="2020 Family Day Lineup for South Peace, Smoky River and Peace River regions" title="2020 Family Day Lineup for South Peace, Smoky River and Peace River regions" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/2020-family-day-lineup-for-south-peace-smoky-river-and-peace-river-regions/"     class="tptn_link"><span class="tptn_title">2020 Family Day Lineup for South Peace, Smoky River&hellip;</span></a><span class="tptn_excerpt"> Following is a lineup of activities on the Family Day weekend. Please attend as many as you can,&hellip;</span></span></li><li><a href="https://southpeacenews.com/province-softens-the-blow/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/uploads/2020/02/12feb20_news6a-64x64.jpg" class="tptn_thumb tptn_featured" alt="Province ‘softens the blow’" title="Province ‘softens the blow’" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/province-softens-the-blow/"     class="tptn_link"><span class="tptn_title">Province ‘softens the blow’</span></a><span class="tptn_excerpt"> Towns like High Prairie will not have to pay for extra policing costs until 2021, but they will&hellip;</span></span></li><li><a href="https://southpeacenews.com/pics-ruff-day-at-pleasantview/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/uploads/2020/02/12feb20_pic2g-64x64.jpg" class="tptn_thumb tptn_featured" alt="PICs - &#039;Ruff&#039; day at Pleasantview" title="PICs - &#039;Ruff&#039; day at Pleasantview" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/pics-ruff-day-at-pleasantview/"     class="tptn_link"><span class="tptn_title">PICs &#8211; &#8216;Ruff&#8217; day at Pleasantview</span></a><span class="tptn_excerpt"> Pleasantview resident Eileen Singleton cuddles an unnamed Pyrenees Rottweiler pup before the show. The pup is ready to&hellip;</span></span></li><li><a href="https://southpeacenews.com/today-in-high-prairie-february-14-2020/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Today in High Prairie - February 14, 2020" title="Today in High Prairie - February 14, 2020" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/today-in-high-prairie-february-14-2020/"     class="tptn_link"><span class="tptn_title">Today in High Prairie &#8211; February 14, 2020</span></a><span class="tptn_excerpt"> Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history&hellip;</span></span></li><li><a href="https://southpeacenews.com/editorial-were-all-too-rich/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Editorial - We’re all too rich" title="Editorial - We’re all too rich" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/editorial-were-all-too-rich/"     class="tptn_link"><span class="tptn_title">Editorial &#8211; We’re all too rich</span></a><span class="tptn_excerpt"> Jeff Burgar In early spring last year, a group of about a dozen snowmobilers had paused for a&hellip;</span></span></li><li><a href="https://southpeacenews.com/today-in-high-prairie-february-8-2020/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Today in High Prairie - February 8, 2020" title="Today in High Prairie - February 8, 2020" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/today-in-high-prairie-february-8-2020/"     class="tptn_link"><span class="tptn_title">Today in High Prairie &#8211; February 8, 2020</span></a><span class="tptn_excerpt"> Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history&hellip;</span></span></li><li><a href="https://southpeacenews.com/today-in-high-prairie-february-11-2020/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Today in High Prairie - February 11, 2020" title="Today in High Prairie - February 11, 2020" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/today-in-high-prairie-february-11-2020/"     class="tptn_link"><span class="tptn_title">Today in High Prairie &#8211; February 11, 2020</span></a><span class="tptn_excerpt"> Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history&hellip;</span></span></li><li><a href="https://southpeacenews.com/today-in-high-prairie-february-13-2020/"     class="tptn_link"><img  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Today in High Prairie - February 13, 2020" title="Today in High Prairie - February 13, 2020" /></a><span class="tptn_after_thumb"><a href="https://southpeacenews.com/today-in-high-prairie-february-13-2020/"     class="tptn_link"><span class="tptn_title">Today in High Prairie &#8211; February 13, 2020</span></a><span class="tptn_excerpt"> Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history&hellip;</span></span></li></ul><div class="tptn_clear"></div></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- AdsenseResponsive01 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3165736599172791"
     data-ad-slot="6075938174"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside></div><!-- #secondary -->
	</main><!-- #main -->

	</div><!-- #content -->

	<div class="clearfix"></div>

	<footer id="footer" class="site-footer clearfix" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
			
			<div class="footer-column footer-column-1">
				<aside id="text-4" class="widget widget_text"><h3 class="widget-title">SUPPORT INFORMATION</h3>			<div class="textwidget"><p><a href="http://southpeacenews.com/contact/">Contact Us</a><br />
<a href="http://southpeacenews.com/about/">About The South Peace News</a><br />
<a href="http://southpeacenews.com/advertising-rates/">Online Advertising Rates</a></p>
</div>
		</aside><aside id="archives-2" class="widget widget_archive"><h3 class="widget-title">ARCHIVES</h3>		<label class="screen-reader-text" for="archives-dropdown-2">ARCHIVES</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://southpeacenews.com/2020/02/'> February 2020 &nbsp;(61)</option>
	<option value='https://southpeacenews.com/2020/01/'> January 2020 &nbsp;(146)</option>
	<option value='https://southpeacenews.com/2019/12/'> December 2019 &nbsp;(152)</option>
	<option value='https://southpeacenews.com/2019/11/'> November 2019 &nbsp;(147)</option>
	<option value='https://southpeacenews.com/2019/10/'> October 2019 &nbsp;(182)</option>
	<option value='https://southpeacenews.com/2019/09/'> September 2019 &nbsp;(143)</option>
	<option value='https://southpeacenews.com/2019/08/'> August 2019 &nbsp;(109)</option>
	<option value='https://southpeacenews.com/2019/07/'> July 2019 &nbsp;(179)</option>
	<option value='https://southpeacenews.com/2019/06/'> June 2019 &nbsp;(148)</option>
	<option value='https://southpeacenews.com/2019/05/'> May 2019 &nbsp;(135)</option>
	<option value='https://southpeacenews.com/2019/04/'> April 2019 &nbsp;(156)</option>
	<option value='https://southpeacenews.com/2019/03/'> March 2019 &nbsp;(117)</option>
	<option value='https://southpeacenews.com/2019/02/'> February 2019 &nbsp;(75)</option>
	<option value='https://southpeacenews.com/2019/01/'> January 2019 &nbsp;(128)</option>
	<option value='https://southpeacenews.com/2018/12/'> December 2018 &nbsp;(90)</option>
	<option value='https://southpeacenews.com/2018/11/'> November 2018 &nbsp;(141)</option>
	<option value='https://southpeacenews.com/2018/10/'> October 2018 &nbsp;(133)</option>
	<option value='https://southpeacenews.com/2018/09/'> September 2018 &nbsp;(111)</option>
	<option value='https://southpeacenews.com/2018/08/'> August 2018 &nbsp;(108)</option>
	<option value='https://southpeacenews.com/2018/07/'> July 2018 &nbsp;(152)</option>
	<option value='https://southpeacenews.com/2018/06/'> June 2018 &nbsp;(120)</option>
	<option value='https://southpeacenews.com/2018/05/'> May 2018 &nbsp;(138)</option>
	<option value='https://southpeacenews.com/2018/04/'> April 2018 &nbsp;(135)</option>
	<option value='https://southpeacenews.com/2018/03/'> March 2018 &nbsp;(151)</option>
	<option value='https://southpeacenews.com/2018/02/'> February 2018 &nbsp;(134)</option>
	<option value='https://southpeacenews.com/2018/01/'> January 2018 &nbsp;(119)</option>
	<option value='https://southpeacenews.com/2017/12/'> December 2017 &nbsp;(133)</option>
	<option value='https://southpeacenews.com/2017/11/'> November 2017 &nbsp;(140)</option>
	<option value='https://southpeacenews.com/2017/10/'> October 2017 &nbsp;(152)</option>
	<option value='https://southpeacenews.com/2017/09/'> September 2017 &nbsp;(130)</option>
	<option value='https://southpeacenews.com/2017/08/'> August 2017 &nbsp;(113)</option>
	<option value='https://southpeacenews.com/2017/07/'> July 2017 &nbsp;(138)</option>
	<option value='https://southpeacenews.com/2017/06/'> June 2017 &nbsp;(153)</option>
	<option value='https://southpeacenews.com/2017/05/'> May 2017 &nbsp;(159)</option>
	<option value='https://southpeacenews.com/2017/04/'> April 2017 &nbsp;(144)</option>
	<option value='https://southpeacenews.com/2017/03/'> March 2017 &nbsp;(142)</option>
	<option value='https://southpeacenews.com/2017/02/'> February 2017 &nbsp;(118)</option>
	<option value='https://southpeacenews.com/2017/01/'> January 2017 &nbsp;(117)</option>
	<option value='https://southpeacenews.com/2016/12/'> December 2016 &nbsp;(151)</option>
	<option value='https://southpeacenews.com/2016/11/'> November 2016 &nbsp;(136)</option>
	<option value='https://southpeacenews.com/2016/10/'> October 2016 &nbsp;(178)</option>
	<option value='https://southpeacenews.com/2016/09/'> September 2016 &nbsp;(154)</option>
	<option value='https://southpeacenews.com/2016/08/'> August 2016 &nbsp;(147)</option>
	<option value='https://southpeacenews.com/2016/07/'> July 2016 &nbsp;(153)</option>
	<option value='https://southpeacenews.com/2016/06/'> June 2016 &nbsp;(172)</option>
	<option value='https://southpeacenews.com/2016/05/'> May 2016 &nbsp;(159)</option>
	<option value='https://southpeacenews.com/2016/04/'> April 2016 &nbsp;(73)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</aside><aside id="text-10" class="widget widget_text"><h3 class="widget-title">PURLS To Brighten Your Day</h3>			<div class="textwidget"><p>Advertiser Sale of The Week &#8211; Coming<br />
Recipe &#8211; Coming<br />
Canada Home of The Week &#8211; Coming<br />
Coffee Break &#8211; Coming<br />
Top Headline &#8211; Coming</p>
<p>&nbsp;</p>
</div>
		</aside>			</div>

			<div class="footer-column footer-column-2">
				<aside id="ajdg_grpwidgets-4" class="widget ajdg_grpwidgets"><div class="g g-6"><div class="g-dyn a-65 c-1"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'We Want News-Side']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'We Want News-Side']);" src="https://southpeacenews.com/wp-content/uploads/2016/10/WeWantNews_side_png.png" /></a></div><div class="g-dyn a-198 c-2"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'NoticeofMeeting_side']);" href=" http://southpeacenews.com/notices/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'NoticeofMeeting_side']);" src="https://southpeacenews.com/wp-content/uploads/2018/01/NoticeOfMeeting_Side.png" /></a></div><div class="g-dyn a-138 c-3"><a onClick="_paq.push(['trackEvent', 'Adverts', 'Click', 'Share Your Scoop side']);" href="http://southpeacenews.com/contact/"><img onload="_paq.push(['trackEvent', 'Adverts', 'Impression', 'Share Your Scoop side']);" src="https://southpeacenews.com/wp-content/uploads/2017/10/ShareYourScoop.png" /></a></div></div></aside>			</div>

			<div class="footer-column footer-column-3">
				<aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe style="border: 1px solid black" src="https://contentkings.com/quotegen01/" width="300" height="340" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></div></aside>			</div>

			<div class="footer-column footer-column-4">
				<aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe style="border: 1px solid black" src="https://contentkings.com/laughgen01/" width="300" height="340" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></div></aside>			</div>

		<div id="site-bottom" class="clearfix">

				<div class="copyright"><div class="left">&copy; 2020 <a href="https://southpeacenews.com" title="" rel="home"></a>. All rights reserved.</div><div class="right">Built by South Peace News</div></div><!-- .copyright -->

		</div>

	</footer><!-- #colophon -->
	
</div><!-- #page -->

    <!-- LikeBtn.com BEGIN -->
    <script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script>
    <!-- LikeBtn.com END -->
            <!-- Custom Facebook Feed JS -->
<script type="text/javascript">
var cfflinkhashtags = "true";
</script>
<script>document.documentElement.className = 'js';</script>
<!-- Matomo -->
<script type="text/javascript">
  var _paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
_paq.push(['trackVisibleContentImpressions']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//southpeacenews.com/matomo/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<!-- End Matomo Code -->
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://southpeacenews.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "96b0998be7", post_id : 30754 } ); } ); /* ]]> */</script>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js?ver=1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/southpeacenews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/plugins/custom-facebook-feed/js/cff-scripts.js?ver=2.12.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/southpeacenews.com\/wp-admin\/admin-ajax.php","top_ten_id":"30754","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"271791745"};
/* ]]> */
</script>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE&#038;ver=3.0'></script>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/themes/freshlife/assets/js/freshlife.min.js'></script>
<script type='text/javascript' src='https://southpeacenews.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://southpeacenews.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://southpeacenews.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='https://southpeacenews.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
	<script type="text/javascript">

		$(document).ready(function(){
			$('#primary-menu').slicknav({
				prependTo:'#primary-bar',
				label: "PAGES"
			});
			$('#secondary-menu').slicknav({
				prependTo:'#secondary-bar',
				label: "CATEGORIES"
			});
		});

	</script>
	<script type="text/javascript">
( function( grecaptcha, sitekey, actions ) {

	var wpcf7recaptcha = {

		execute: function( action ) {
			grecaptcha.execute(
				sitekey,
				{ action: action }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		},

		executeOnHomepage: function() {
			wpcf7recaptcha.execute( actions[ 'homepage' ] );
		},

		executeOnContactform: function() {
			wpcf7recaptcha.execute( actions[ 'contactform' ] );
		},

	};

	grecaptcha.ready(
		wpcf7recaptcha.executeOnHomepage
	);

	document.addEventListener( 'change',
		wpcf7recaptcha.executeOnContactform, false
	);

	document.addEventListener( 'wpcf7submit',
		wpcf7recaptcha.executeOnHomepage, false
	);

} )(
	grecaptcha,
	'6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE',
	{"homepage":"homepage","contactform":"contactform"}
);
</script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:8000,repeat_impressions:'Y'});
	jQuery('.g-2').gslider({groupid:2,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-4').gslider({groupid:4,speed:8000,repeat_impressions:'Y'});
	jQuery('.g-5').gslider({groupid:5,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-6').gslider({groupid:6,speed:7000,repeat_impressions:'Y'});
	jQuery('.g-7').gslider({groupid:7,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-8').gslider({groupid:8,speed:6000,repeat_impressions:'Y'});
}});
</script>
<!-- /AdRotate JS -->


</body>
</html>